Release Notes

Titanium Mobile 1.8.1 - 1/31/2012

Titanium Mobile Release 1.8.1 is a patch set release that includes fixes for known issues in Release 1.8.0.1, as well as stability and parity improvements.

Please see the updated Titanium Mobile Reference Documentation for 1.8.1.

Full list of Issues that were addressed in 1.8.1

Significant Changes In Titanium Mobile

Known Issues

The following are known issues in Release 1.8.1:

We are actively working on fixes for these issues, and plan to have fixes available in the continuous integration (CI) build in the next week.

Android Changes

The following sections list notable new features and bug fixes in Android.

New Feature

Bug Fixes:

For a complete list of Android fixes in this release, see: Fixed Android Issues in JIRA.

iOS Changes

The following sections list notable new features and bug fixes in iOS.

New Features

Bug Fixes:

For a complete list of iOS fixes in this release, see: Fixed iOS Issues in JIRA.

Mobile Web Changes

This release includes a significant increase in feature coverage on Mobile Web. In particular, the following UI objects are at or near parity with the other platforms:

For a complete list of Mobile Web fixes in this release, see: Fixed Mobile Web Issues in JIRA.

Documentation Changes

This release includes a number of documentation fixes and enhancements, including:

Fixed Documentation Issues in JIRA

Requirements for Building Android Modules on Windows

Building Android modules on Windows requires the following:

Updating Native JavaScript Modules for iOS

You may need to update your iOS modules if either of the following applies to you:

If either of the above conditions apply, you should update your module's build.py file and rebuild your module.

  1. Download the build.py patch file from: https://gist.github.com/1586163

  2. From the top-level directory of your module project, run this command to patch your build.py file:

    patch -p4 /build.py.patch

  3. Rebuild your module with build.py.

Note that new modules created with release 1.8.1 do not need to be patched.